読者です 読者をやめる 読者になる 読者になる

oranie's blog

旧:iをgに変えると・・・なんだっけ・・・

#fluentd GrowthForecastでグラフ描画がエラーになってしまう対処方法

設定とかの話

環境:SL6.2 64bitでやりました。

http://blog.nomadscafe.jp/2011/12/growthforecast.html
http://d.hatena.ne.jp/tagomoris/20120218/1329558305
のままです。今Cacti使っているけど、fluentd+datacounterとかでガンガングラフ作ろうと思うと死ねるので、新しいグラフツールを導入すべくGrowthForecastを使ってみた。

問題について

fluentd側の設定も終わりブラウザからアクセスすると、currentの値は入っているのにグラフが描画されない。サーバ側のエラーログでこんなの出ていた。

で原因はrrdtoolが古い為に、このログに書かれている通りborderオプションが使えなかった為っぽい。
SL6.2だとデフォルトでyumで入れると

rrdtool-devel-1.3.8-6.el6.x86_64                                                                               rrdtool-perl-1.3.8-6.el6.x86_64                                                                          rrdtool-1.3.8-6.el6.x86_64       

が入る。これをアップデートする為、http://oss.oetiker.ch/rrdtool/download.en.htmlからVer:1.4.5-1を落としてきてアップデートしたら成功した!

で、flowcounter側ではこんな感じでログを出して、

    <store>
        type flowcounter
        count_keys *
        aggregate  all
        tag        traffic.apache
    </store>

growthforecast側では

    <store>
        type growthforecast
        gfapi_url http://localhost:5125/api/
        service   service1
        section   traffic.apache
        name_keys count
    </store>

こんな感じの設定入れたらこんなのが出来ました。http://gyazo.com/b5045b743f14268294017a2bf453017f

とってもお手軽ですね!!!