読者です 読者をやめる 読者になる 読者になる

oranie's blog

旧:iをgに変えると・・・なんだっけ・・・

環境設定続き

構築したLinuxは最小設定なので環境として
ruby1.8.6インストール
postgresqlインストール
gemインストール
dbiインストールを行った。
というか
yum -y inastall ruby
だと1.8.2がインストールされるのは止めて欲しい・・・。
いい加減アップデートしてくれないかな・・・。

dbiの参考サイトは

http://www.cozmixng.org/~kou/ruby/ruby_dbi
http://www.jiubao.org/ruby-dbi/ruby-dbi.html#TOC_4

を見た。
dbiのインストール時にpostgresql用の
ruby setup.rb config --with=Pg
をせずにインストールしてpostgresqlドライバが用意されないというエラーでかなり躓いた・・・。
何も引数付けないと対応ドライバ全部設定するはずなのに・・・なんでだろう?
DBI.available_drivers
の使い方もよくわからないし・・・。